There are too many records to support rollback protection

When manually importing data from any import module into a Microsoft Access database, the following message appears:

There are too many records to support rollback protection.
Please disable rollback protection and try importing again.

Cause

When manually importing records into an AYS database, clicking the Test button imports all of the data but keeps track of all changes made so that those changes can be undone or rolled back at the end of the test. Warnings or errors that are logged during this test may be used to clean up the data set being imported before any live data in the target database is affected. Clicking the Import button still keeps track of all changes made so that if there is a critical error during the import then any changes can still be undone or rolled back.

When importing data into Microsoft Access databases, there is a limit as to how much data can be recorded in the list of changes. The above error indicates that the limit has been reached and a decision must be made to either undo the changes now, or continue without the ability to undo any changes.

Resolution

Option 1: If you are satisfied that the import data set is good then within the import module select the Options tab, and check the box next to Disable Rollback Protection. Once this option is checked then the Test button will  no longer be available. Click the Import button to proceed with the import.

Option 2: If you are not satisfied that the import data set is good then break the data set into smaller chunks and test importing each chunk of data individually. Once you are satisfied that the import data set is good then you may either import each chunk of data individually, or import the entire data set. Follow the steps in Option 1 above to disable rollback protection before importing.

How do I install my AYS license?

If you have received your license file via email from At Your Service, you can apply the license to your installed trial version of AYS to unlock all of the features covered by that license. The process may be slightly different based on the version of AYS you have installed.

How do I configure AYS to use my local currency settings?

If At Your Service software is installed on a local workstation, then the currency symbol displayed and printed will be the same symbol configured in the Windows regional settings on that local workstation.

If At Your Service software is installed on a server that is being accessed remotely (e.g. via remote desktop or Citrix server), then the currency symbol displayed and printed will be the same symbol configured in the Windows regional settings on the server.