When running AYS using Windows Remote Desktop Services or Windows Terminal Services, the following message appears:
At Your Service – Repair Centre has stopped working
Windows can check online for a solution to the problem.
- Check online for a solution and close the program
- Close the program
View problem details
When you click the dropdown button next to View problem details a message similar to one of the following appears:
Problem signature:
Problem Event Name: BEX
Application Name: AYS.exe
Problem signature:
Problem Event Name: BEX
Application Name: AYSINet.exe
Cause
This is a known problem with Windows Remote Desktop Services (formerly Windows Terminal Services) as documented by Microsoft in their knowledge base article 2279689.
The problem most often occurs within AYS when printing a report or form that includes QR codes, whether or not the QR codes are configured to print.
Resolution
Automatic Resolution
BEX errors can be resolved by configuring Data Execution Prevention (DEP) for AYS.exe and AYSINet.exe. To automatically configured these settings, execute the following steps:
Step 1: Download and install service pack 3.4.036 or higher from the AYS web site.
Step 2: From the Windows Start menu, select All Programs > At Your Service > Utilities > Configure DEP for AYS. A script will automatically configure Data Execution Prevention settings for AYS. Accept the confirmation prompts to complete the configuration.
Manual Resolution
Optionally, Data Execution Prevention settings can be configured manually by executing the following steps on the Windows Server:
Step 1: Within File Explorer (formerly Windows Explorer), right-click on Computer and select Properties from the context menu.
Step 2: Click Advanced system settings.
Step 3: Select the Advanced tab and click the Settings button under the heading Performance.
Step 4: Select the Data Execution Prevention tab and select the option Turn on DEP for all programs and services except those I select.
Step 5: Click the Add button and navigate to select AYS.exe and AYSINet.exe from the folder where AYS was installed. The default installation folder on 32-bit operating systems is C:\Program Files\At Your Service. The default installation folder on 64-bit operating systems is C:\Program Files (x86)\At Your Service.
AYS Internet Utility Service
BEX errors may occur when the AYS Internet Utility is running as a service. In most cases the above automatic or manual resolution steps will resolve the problem. However, if User Access Control (UAC) is enabled then the service may not recognize the DEP settings and it may be necessary to tell the service to run under the identity of a Windows Administrator user. Therefore, if the errors persist after configuring DEP then execute the following steps:
Step 1: Open the Windows Services manager.
Step 2: Right-click on the AYS Internet Utility service and select Properties from the context menu
Step 3: Select the Log On tab.
Step 4: Select This account and enter the user name and password of a Windows administrator user.
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